Updating firmware on Zooz Water Leak Sensor (ZSE42)

I made a post about it on r/homeassistant without much response so I figured I’d ask here.

I’m trying to update the firmware for some Z-Wave Zooz Water Leak Sensors (ZSE42) via Home Assistant but not having much luck. I’m first waking up the sensors by clicking the small black button inside four times per the Zooz instructions, then clicking “Install” in Home Assistant for the firmware update. It says “Installing” but looking at the events log for the device in the ZWaveJS UI, it looks like the device just goes back to sleep after a minute.

Any tips on how to update the firmware on these battery powered devices that only wake up for a short period?

Hi there! You’ll want to make sure you initiate the update, then wake the sensor. Depending on how long the update takes, you may need to wake the sensor multiple times. If the sensor is a long distance from the hub, excluding it and re-including it near the hub and without S2 security should help the update progress expediently.

I did try that but was not having luck, so I tried a different water leak sensor and it worked. I was able to get the original sensor I was having issues with to update, so I’ll post my experience here in hopes to help someone else out in the future. I think it would be worthwhile to have a section on the Zooz website that explains firmware updates for battery powered devices (maybe it’s there but I could not find it).

How the update process should work:

To update Zooz battery powered devices, as mentioned above:

  1. Initiate the update through Home Assistant, Z-Wave JS, etc.
  2. Wake up the sensor by quickly pressing the small black button inside the sensor four times (you’ll have to take off the cover). You should see the blue LED light up for a second or so then turn off, letting you know the sensor is awake.

From what I observed, once the update started, the device remained awake until the update finished. It took approximately 5-10 minutes to complete, and I believe used a lot of battery (went from 100% to 25%, although I realize the battery readings are very unreliable).

Issues I had:

One of my devices was not updating despite following the steps above. The first time I tried to update the firmware, it never finished and just got stuck at some percentage despite leaving it there for multiple days. When I tried updating it again, the update wouldn’t even start despite the fact I could see it waking up in the Z-Wave JS GUI but then several seconds later, go back to sleep. When I tried again, I don’t think the device was even waking up anymore because I was not seeing the blue LED turn on.

After removing the battery and reinserting it, I followed the steps above and everything seemed to update correctly.


I also forgot to note, after I updated the firmware on a couple of my Zooz Water Leak Sensors, the battery percentage went from 100% to 0%. I left it alone for a day and it updated to around 84%. The sensor I was referencing in my post above that went from 100% to 25% also updated back up to 100%. Bottom line, battery levels for battery powered devices are pretty unreliable to begin with but even more so after a firmware update.

1 Like

I’ve also noticed this recently. My ZSE42 battery level has been all over the place since a recent water intrusion issue–I’ve been watching it several times/day to be sure there isn’t more water!

Zooz: is battery level a known problem with this device? Any known solutions–or is/was this addressed in a firmware update for the device?

Tagging @Sara

Firmware 1.50 for the 700 series ZSE42 addressed issues with battery status display when added using S2 authenticated security on select platforms.

The battery on ZSE42 800LR is now a CR2450 (vs the CR2032 on ZSE42 700). With the CR2032 coin battery you’re looking at a smaller capacity than the lithium CR batteries used in other sensors, so you may see the battery readings fluctuate from low to higher readings when the sensor is awake during programming and testing. The battery will usually go back to its stable reading within a few hours so always allow a day or two after you see the first lower reading before checking on the actual battery life left for your device.

Thanks, @Sara! My ZSE42 in question–I believe it’s 700 series; has the CR2032–was updated to v1.50 this fall before we left. It is connected with S2 security. So, I guess battery life is as good as it’s going to get. The battery was new in the fall.

This morning the water sensor showed as ‘Offline,’ but with 36% battery on my SmartThings hub. If it doesn’t come back to life in the next 24 hours, perhaps I can have my daughter drive over from the next town and walk her through putting in a new battery, as we won’t be home for another week or so. I’m concerned because of the aforementioned basement water intrusion incident, where it alerted us in time to get things cleaned up before mold started growing down there.